Sign in to follow this  
Followers 0
BarryMacLaren

Garmin 62s Windows 10 Connection

5 posts in this topic

Windows 10 does not recognize my Garmin 62s on USB connection.

This topic is present on both Microsoft and Garmin forums ( for several Garmin models) however to date neither offers a solution that has worked.

Has anyone experienced and solved a similar issue?

Share this post


Link to post
Share on other sites

I don't have a 62S but regularly connect my Montana 650,Oregon 550, and Map78s using Win 10 and EGPS.

Are you using the Genuine Garmin micro USB cable, and have you updated to the latest Garmin USB drivers? (these are two Musts)

On your GPS, go into Settings, System, Interface....choose Garmin Spanner.

Try this sequence....With your GPS off, plug in the Garmin cable (already plugged in to your PC, NOT a USB hub)

The first thing I see then on the PC is an error message in the lower RH corner of the screen "USB Device Not Recognized"...IGNORE THAT.

That is just a result of your PC processor being faster than your GPS processor (Common Sense says... Of Course)

Then watch on your GPS screen, it will ask you if you want to go into USB Mass Storage mode, click on Yes.

In a few seconds you'll hear the PC make the successful USB connection sound and, (if you want to look) both the GPS unit and the mSD card should show up in Windows Explorer as separate drives.

At that point, you should be good to go.

That's what works for me, Hope it works for you,

 

 

 

Share this post


Link to post
Share on other sites

Thanks for your reply

Genuine Garmim cable is in use and all drivers have been updated.

I followed your directions through to the Mass Storage prompt and replied accordingly however the Garmin still isn't recognized.

I had no problems at all when running on Window 7

Share this post


Link to post
Share on other sites

What did Garmin tech support say?

Share this post


Link to post
Share on other sites

I haven't submitted a query directly to Garmin but their posts to others with similar issues suggests they think the problem is with Windows 10.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0